All Apple Watch apps required to use native SDK from June 1

25 April, 2016
Apple has informed the developers that all Apple Watch apps will be required to use the native SDK starting June 1.

Sort by:

  • Anonymous

ugly overpriced watch. lol.

  • woopwoop777

Anonymous, 25 Apr 2016Perhaps android is ahead but its glitchy as heck I have had a mo... moreyeah and the other day you switched from the s7 to the iphone 6s do 111111 trolll

  • Anonymous

Perhaps android is ahead but its glitchy as heck I have had a moto 360 first gen and it was a nightmare now I see the difference on apple watch and I have to say will probably never go back to android. So they say once you go Mac you never go back :)

  • Anonymous

Android Wear is ahead of WatchOS imo