Nearly a billion Android devices affected by newly-discovered 'QuadRooter'

Himanshu, 08 August, 2016

Researchers at security firm Check Point have revealed a new flaw that they say affects Android devices powered by Qualcomm chipsets. Dubbed QuadRooter, the flaw is basically a set of four vulnerabilities affecting over 900 million smartphones and tablets running Google's mobile operating system, including Samsung's latest Galaxy S7 flagships as well as the BlackBerry DTEK50, which is claimed to be "the world's most secure Android smartphone."

If exploited, the security flaw can give attackers complete control of affected phone or tablet, including access to sensitive personal and enterprise information stored on the device. To carry out a successful takeover, all the attacker needs is to trick the user into installing a malicious app that wouldn't require any special permissions.

Qualcomm was notified about the vulnerabilities - found in the company's software drivers - back in April this year. The chipmaker says that all the bugs were fixed at its end and patches were handed over to customers. While fix for three vulnerabilities have already made it to recent Android monthly security updates released by Google, one is still outstanding - it'll be be included in the September update.

It's worth mentioning that Check Point has also released a free QuadRooter Scanner app on Google Play, using which you can confirm whether or not these vulnerabilities exist on your device.

Source | Via | QuadRooter Scanner


Related

Reader comments

  • Anonymous

youre phone is vulnerable not u...

  • Anonymous

hahahahahhaaaa>>>>lolol

  • Anonymous

use micomax only